Project

General

Profile

Bug #9310

inheritance.rb: 27: [BUG] Segmentation fault at 0x00000c

Added by jasnow (Al Snow) over 6 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.1.0p0 (2013-12-25 revision 44422) [i686-linux]
[ruby-core:59345]

Description

inheritance.rb:27: [BUG] Segmentation fault at 0x00000c

5 failed 24pullrequest.com rspecs after Ruby 2.1 upgrade

Steps to reproduce:

  1. Clone https://github.com/andrew/24pullrequests
  2. Run "unset GITHUB_KEY" to turn off this env variable.
  3. Run "rake" before "2.1.0" change to see they all run green.
  4. Changed .ruby-version and Gemfile "ruby" line to 2.1.0.
  5. Run any of these rspecs to see failed rspecs (they all fail):
    • rspec spec/controllers/gifts_controller_spec.rb
    • rspec spec/models/pull_request_spec.rb
    • rspec spec/models/user_spec.rb
    • rspec spec/requests/dashboard_spec.rb
    • rspec spec/requests/gifts_spec.rb
  6. Gist of output is here: https://gist.github.com/jasnow/8148894
    • Search for "=====" as the divider between rspecs.
  7. Environment:
    • Hardware: Dell M1710 (32bit; laptop)
    • OS: Ubuntu 13.10
    • Memory: 4 GB

Related issues

Is duplicate of Ruby master - Bug #9309: Crash while running testsClosed12/27/2013Actions

Updated by wanabe (_ wanabe) over 6 years ago

I can reproduce with 2.1.0p0 but not with r44459 (trunk).
And git-bisect said it hasn't occurred after r44455.
I guess the ticket is a duplication of #9315.

Updated by hsbt (Hiroshi SHIBATA) over 6 years ago

  • Status changed from Open to Feedback

Could you try to test with ruby trunk?

Updated by nobu (Nobuyoshi Nakada) about 6 years ago

Updated by nobu (Nobuyoshi Nakada) about 6 years ago

Updated by nobu (Nobuyoshi Nakada) about 6 years ago

  • Related to Bug #9309: Crash while running tests added

Updated by nobu (Nobuyoshi Nakada) about 6 years ago

  • Related to deleted (Bug #9309: Crash while running tests)

Updated by nobu (Nobuyoshi Nakada) about 6 years ago

  • Is duplicate of Bug #9309: Crash while running tests added
#8

Updated by hsbt (Hiroshi SHIBATA) about 6 years ago

  • Status changed from Feedback to Closed

fixed by r44777 . Please wait next minor release of 2.1

Updated by usa (Usaku NAKAMURA) about 6 years ago

  • Backport changed from 1.9.3: UNKNOWN, 2.0.0: UNKNOWN, 2.1: UNKNOWN to 1.9.3: DONTNEED, 2.0.0: DONTNEED, 2.1: UNKNOWN

Also available in: Atom PDF