Bug #9320

Nightly Snapshot is not found

Added by Heesob Park over 1 year ago. Updated 7 months ago.

[ruby-core:59393]
Status:Closed
Priority:Normal
Assignee:-
ruby -v:ruby-2.2.0-r44459 Backport:1.9.3: DONTNEED, 2.0.0: DONTNEED, 2.1: DONE

Description

If I click the Nightly Snapshot link on the http://www.ruby-lang.org/en/downloads/, It raised "404 Not Found" error.

When I try to build the latest snapshot,

ruby tool/make-snapshot /tmp/snapshot/ trunk

Exporting trunk@44459
Exported revision 44459.
take a breath, and go ahead
creating configure... done
creating prerequisites...
generating id.h
id.h updated
generating opt_sc.inc
generating optinsn.inc
generating optunifs.inc
generating insns.inc
generating insns_info.inc
generating vmtc.inc
generating vm.inc
generating node_name.inc
generating encdb.h
encdb.h updated
rbconfig.rb updated
generating enc.mk
/tmp/ruby-snapshot20131230-4403-fmvml0/ruby-2.2.0-r44459/lib/mkmf.rb:2401:in dup': can't dup NilClass (TypeError)
from /tmp/ruby-snapshot20131230-4403-fmvml0/ruby-2.2.0-r44459/lib/mkmf.rb:2401:in
init_mkmf'
from /tmp/ruby-snapshot20131230-4403-fmvml0/ruby-2.2.0-r44459/lib/mkmf.rb:2484:in <module:MakeMakefile>'
from /tmp/ruby-snapshot20131230-4403-fmvml0/ruby-2.2.0-r44459/lib/mkmf.rb:47:in
'
from ./enc/make_encmake.rb:8:in load'
from ./enc/make_encmake.rb:8:in
'
make: *** [enc.mk] Error 1
prerequisites failed

This error was introduced with r44459.

Associated revisions

Revision 44460
Added by Hirofumi WATANABE over 1 year ago

  • tool/make-snapshot: needs CXXFLAGS. [Bug #9320]

Revision 44460
Added by Hirofumi WATANABE over 1 year ago

  • tool/make-snapshot: needs CXXFLAGS. [Bug #9320]

History

#1 Updated by Hiroshi SHIBATA over 1 year ago

phasis68

Thank you for your report. 404 error of ruby-lang.org is caused by r44459 too.

#2 Updated by Hirofumi WATANABE over 1 year ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r44460.
Heesob, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


  • tool/make-snapshot: needs CXXFLAGS. [Bug #9320]

#3 Updated by Usaku NAKAMURA about 1 year ago

  • Backport changed from 1.9.3: UNKNOWN, 2.0.0: UNKNOWN, 2.1: UNKNOWN to 1.9.3: REQUIRED, 2.0.0: REQUIRED, 2.1: REQUIRED

#4 Updated by Usaku NAKAMURA about 1 year ago

  • Backport changed from 1.9.3: REQUIRED, 2.0.0: REQUIRED, 2.1: REQUIRED to 1.9.3: DONTNEED, 2.0.0: DONTNEED, 2.1: DONTNEED

#5 Updated by Tomoyuki Chikanaga 7 months ago

  • Backport changed from 1.9.3: DONTNEED, 2.0.0: DONTNEED, 2.1: DONTNEED to 1.9.3: DONTNEED, 2.0.0: DONTNEED, 2.1: DONE

r44460 was already backported (with r44425) into ruby_2_1 at r45162. Though I don't know why it is required...

Also available in: Atom PDF