Project

General

Profile

Bug #9320

Nightly Snapshot is not found

Added by phasis68 (Heesob Park) almost 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:59393]

Description

If I click the Nightly Snapshot link on the http://www.ruby-lang.org/en/downloads/, It raised "404 Not Found" error.

When I try to build the latest snapshot,

ruby tool/make-snapshot /tmp/snapshot/ trunk

Exporting trunk@44459
Exported revision 44459.
take a breath, and go ahead
creating configure... done
creating prerequisites...
generating id.h
id.h updated
generating opt_sc.inc
generating optinsn.inc
generating optunifs.inc
generating insns.inc
generating insns_info.inc
generating vmtc.inc
generating vm.inc
generating node_name.inc
generating encdb.h
encdb.h updated
rbconfig.rb updated
generating enc.mk
/tmp/ruby-snapshot20131230-4403-fmvml0/ruby-2.2.0-r44459/lib/mkmf.rb:2401:in dup': can't dup NilClass (TypeError)
from /tmp/ruby-snapshot20131230-4403-fmvml0/ruby-2.2.0-r44459/lib/mkmf.rb:2401:in
init_mkmf'
from /tmp/ruby-snapshot20131230-4403-fmvml0/ruby-2.2.0-r44459/lib/mkmf.rb:2484:in <module:MakeMakefile>'
from /tmp/ruby-snapshot20131230-4403-fmvml0/ruby-2.2.0-r44459/lib/mkmf.rb:47:in
'
from ./enc/make_encmake.rb:8:in load'
from ./enc/make_encmake.rb:8:in
'
make: *** [enc.mk] Error 1
prerequisites failed

This error was introduced with r44459.

Associated revisions

Revision 44460
Added by eban (Hirofumi WATANABE) almost 4 years ago

  • tool/make-snapshot: needs CXXFLAGS. [Bug #9320]

Revision 44460
Added by eban (Hirofumi WATANABE) almost 4 years ago

  • tool/make-snapshot: needs CXXFLAGS. [Bug #9320]

Revision 44460
Added by eban (Hirofumi WATANABE) almost 4 years ago

  • tool/make-snapshot: needs CXXFLAGS. [Bug #9320]

Revision 44460
Added by eban (Hirofumi WATANABE) almost 4 years ago

  • tool/make-snapshot: needs CXXFLAGS. [Bug #9320]

History

#1 [ruby-core:59394] Updated by hsbt (Hiroshi SHIBATA) almost 4 years ago

phasis68

Thank you for your report. 404 error of ruby-lang.org is caused by r44459 too.

#2 Updated by eban (Hirofumi WATANABE) almost 4 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r44460.
Heesob, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


  • tool/make-snapshot: needs CXXFLAGS. [Bug #9320]

#3 [ruby-core:60500] Updated by usa (Usaku NAKAMURA) almost 4 years ago

  • Backport changed from 1.9.3: UNKNOWN, 2.0.0: UNKNOWN, 2.1: UNKNOWN to 1.9.3: REQUIRED, 2.0.0: REQUIRED, 2.1: REQUIRED

#4 [ruby-core:60713] Updated by usa (Usaku NAKAMURA) almost 4 years ago

  • Backport changed from 1.9.3: REQUIRED, 2.0.0: REQUIRED, 2.1: REQUIRED to 1.9.3: DONTNEED, 2.0.0: DONTNEED, 2.1: DONTNEED

#5 [ruby-core:65043] Updated by nagachika (Tomoyuki Chikanaga) over 3 years ago

  • Backport changed from 1.9.3: DONTNEED, 2.0.0: DONTNEED, 2.1: DONTNEED to 1.9.3: DONTNEED, 2.0.0: DONTNEED, 2.1: DONE

#6 [ruby-core:76356] Updated by flamingo123 (flamingo videosservice) over 1 year ago

  • Subject changed from Nightly Snapshot is not found to nice
  • Project changed from Ruby trunk to CommonRuby
  • Tracker changed from Bug to Feature

#7 [ruby-core:76357] Updated by hsbt (Hiroshi SHIBATA) over 1 year ago

  • Backport set to 2.1: UNKNOWN, 2.2: UNKNOWN, 2.3: UNKNOWN
  • Subject changed from nice to Nightly Snapshot is not found
  • Project changed from CommonRuby to Ruby trunk
  • Tracker changed from Feature to Bug

#8 [ruby-core:76365] Updated by znz (Kazuhiro NISHIYAMA) over 1 year ago

  • Backport changed from 2.1: UNKNOWN, 2.2: UNKNOWN, 2.3: UNKNOWN to 2.0.0: DONTNEED, 2.1: DONE

Also available in: Atom PDF