Bug #9399

[PATCH] iseq: avoid potential memory leak in iseq_load

Added by Eric Wong about 1 year ago. Updated about 1 year ago.

[ruby-core:<unknown>]
Status:Closed
Priority:Low
Assignee:Nobuyoshi Nakada
ruby -v:trunk 44559 Backport:1.9.3: DONE, 2.0.0: DONE, 2.1: DONE

Description

The following changes since commit 0e9cad9a8e25282be170d3e4240bd2ba6ce1a419:

test_bigmath.rb: r44558 (2014-01-11 10:26:07 +0000)

are available in the git repository at:

git://80x24.org/ruby.git iseq_load-leak

for you to fetch changes up to f20a86e494226144d9b722daac480f3b1c19d650:

iseq: avoid potential memory leak in iseq_load (2014-01-11 20:38:38 +0000)


Eric Wong (1):
iseq: avoid potential memory leak in iseq_load

iseq.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

0001-iseq-avoid-potential-memory-leak-in-iseq_load.patch Magnifier (862 Bytes) Eric Wong, 01/11/2014 08:43 PM

Associated revisions

Revision 44568
Added by Nobuyoshi Nakada about 1 year ago

iseq.c: potential memory leak

  • iseq.c (iseq_load): keep type_map to get rid of memory leak. based on a patch by Eric Wong at . [Bug #9399]

Revision 44568
Added by Nobuyoshi Nakada about 1 year ago

iseq.c: potential memory leak

  • iseq.c (iseq_load): keep type_map to get rid of memory leak. based on a patch by Eric Wong at . [Bug #9399]

History

#1 Updated by Tomoyuki Chikanaga about 1 year ago

  • Assignee changed from Koichi Sasada to Nobuyoshi Nakada
  • Category set to core
  • Status changed from Open to Closed

fixed by r44568.

#2 Updated by Usaku NAKAMURA about 1 year ago

  • Backport changed from 1.9.3: UNKNOWN, 2.0.0: UNKNOWN, 2.1: UNKNOWN to 1.9.3: REQUIRED, 2.0.0: REQUIRED, 2.1: REQUIRED

#3 Updated by Usaku NAKAMURA about 1 year ago

  • Backport changed from 1.9.3: REQUIRED, 2.0.0: REQUIRED, 2.1: REQUIRED to 1.9.3: DONE, 2.0.0: REQUIRED, 2.1: REQUIRED

backported into ruby_1_9_3 at r44946.

#4 Updated by Yui NARUSE about 1 year ago

  • Backport changed from 1.9.3: DONE, 2.0.0: REQUIRED, 2.1: REQUIRED to 1.9.3: DONE, 2.0.0: REQUIRED, 2.1: DONE

r45105.

#5 Updated by Tomoyuki Chikanaga about 1 year ago

  • Backport changed from 1.9.3: DONE, 2.0.0: REQUIRED, 2.1: DONE to 1.9.3: DONE, 2.0.0: DONE, 2.1: DONE

r44568 was backported to ruby_2_0_0 at r45108.

Also available in: Atom PDF