Project

General

Profile

Bug #9817

The extconf.rb for OpenSSL assumes MingW

Added by djberg96 (Daniel Berger) about 5 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
openssl
Target version:
-
ruby -v:
ruby 2.1.1p76 (2014-02-24 revision 45161) [i386-mswin32_100]
[ruby-core:62463]

Description

It appears that the extconf.rb file for openssl assumes mingw. The problem is that gdi32 and wsock32 need to be linked, even for Visual Studio.

The simple fix is to change "if $mingw" to "if File::ALT_SEPARATOR" on line 40.


Related issues

Related to Ruby trunk - Bug #13080: [mingw regression] broken openssl extension in 2.4.0p0ClosedActions

History

Updated by usa (Usaku NAKAMURA) about 5 years ago

I didn't notice this by now, because there was no problem for building mswin at all.
Are these lines really necessary on mingw?

Updated by djberg96 (Daniel Berger) about 4 years ago

Can we get this changed please?

Updated by nobu (Nobuyoshi Nakada) about 4 years ago

  • Description updated (diff)

gdi32 and wsock32 are Windows specific but File::ALT_SEPARATOR is not.

I'm not sure if they are necessary or not on mingw.

#4

Updated by zzak (Zachary Scott) almost 4 years ago

  • Assignee set to openssl

Updated by djberg96 (Daniel Berger) over 3 years ago

Looking at the source code, File::ALT_SEPARATOR only appears to be defined on Windows. It's set in file.c if DOSISH is defined, and the DOSISH macro is set in defines.h if _WIN32 is defined.

In any case, it's definitely not limited to $mingw.

Updated by nobu (Nobuyoshi Nakada) over 3 years ago

  • Status changed from Open to Feedback

First of all, from where did your "openssl" libraries come?
ws2_32.lib should be linked by the default, and I can't get why openssl needs GDI.

#7

Updated by rhenium (Kazuki Yamaguchi) over 1 year ago

  • Related to Bug #13080: [mingw regression] broken openssl extension in 2.4.0p0 added
#8

Updated by rhenium (Kazuki Yamaguchi) over 1 year ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF