Project

General

Profile

Bug #10657

2.2: Generated binaries misses resource information (MinGW)

Added by luislavena (Luis Lavena) over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Target version:
ruby -v:
ruby 2.2.0p1 (2014-12-26) [i386-mingw32]
[ruby-core:67153]

Description

Binaries (ruby.exe and rubyw.exe) generated from ruby_2_2 branch or released package do not include resource (.rc) information.

Both files (ruby.rc and rubyw.rc) were generated, but seems no longer linked into the executable.

Resource information is required for Ruby executables to be properly identified by both users and automatic check tools.

Updated by nobu (Nobuyoshi Nakada) over 5 years ago

  • Status changed from Assigned to Feedback

I can't reproduce it with i686-w64-mingw32 on darwin and cygwin.
What's your "mingw"?

Updated by luislavena (Luis Lavena) over 5 years ago

Nobuyoshi Nakada wrote:

I can't reproduce it with i686-w64-mingw32 on darwin and cygwin.
What's your "mingw"?

mingw-w64: gcc.exe (rubenvb-4.7.2-release) 4.7.2

Seems the problem is caused by make all, since running make ruby.exe actually embeds the resource.

Updated by nobu (Nobuyoshi Nakada) over 5 years ago

  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

Applied in changeset r49042.


GNUmakefile.in: append resources always

  • cygwin/GNUmakefile.in (EXTOBJS): override to add resource files always. [ruby-core:67153] [Bug #10657]

Updated by hsbt (Hiroshi SHIBATA) over 5 years ago

  • Backport changed from 2.0.0: UNKNOWN, 2.1: UNKNOWN, 2.2: UNKNOWN to 2.0.0: UNKNOWN, 2.1: UNKNOWN, 2.2: REQUIRED

Updated by nobu (Nobuyoshi Nakada) over 5 years ago

  • Backport changed from 2.0.0: UNKNOWN, 2.1: UNKNOWN, 2.2: REQUIRED to 2.0.0: DONTNEED, 2.1: DONTNEED, 2.2: REQUIRED

Updated by naruse (Yui NARUSE) over 5 years ago

  • Backport changed from 2.0.0: DONTNEED, 2.1: DONTNEED, 2.2: REQUIRED to 2.0.0: DONTNEED, 2.1: DONTNEED, 2.2: DONE

ruby_2_2 r49087 merged revision(s) 49042.

Also available in: Atom PDF