Project

General

Profile

Bug #10952

Clarify BigDecimal license

Added by vo.x (Vit Ondruch) over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
[ruby-core:68466]

Description

The README [1] says:

You can redistribute it and/or modify it under either the terms of the GPL
(see COPYING file), or the conditions below:

So it is GPL or Ruby license. Nevertheless, the file headers [2, 3] says something different while referring back to the README.:

* You may distribute under the terms of either the GNU General Public
* License or the Artistic License, as specified in the README file
* of this BigDecimal distribution.

Could you please clarify the licenses?

[1] https://github.com/ruby/ruby/blob/trunk/ext/bigdecimal/README#L5
[2] https://github.com/ruby/ruby/blob/trunk/ext/bigdecimal/bigdecimal.c#L7
[3] https://github.com/ruby/ruby/blob/trunk/ext/bigdecimal/bigdecimal.h#L7

#1

Updated by mrkn (Kenta Murata) over 5 years ago

  • Assignee set to mrkn (Kenta Murata)
#2

Updated by mrkn (Kenta Murata) over 5 years ago

  • Status changed from Open to Assigned
#3

Updated by zzak (Zachary Scott) over 5 years ago

Can we just add it to the gemspec?

#4

Updated by vo.x (Vit Ondruch) over 5 years ago

Stating something in .gemspec which is not aligned with the rest of files does not help.

#5

Updated by mrkn (Kenta Murata) over 5 years ago

I want to change BigDeciaml's licence to the same license of Ruby.
Now I'm contacting to the original author of BigDecimal.

#6

Updated by mrkn (Kenta Murata) over 5 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

Applied in changeset r50185.


  • bigdecimal: conform to ruby's license. [ruby-core:68466] [Bug #10952]
#7

Updated by mrkn (Kenta Murata) over 5 years ago

Shigeo, original author of BigDecimal, allows me to change BigDecimal's license to ruby's.
I'd already changed it.

#8

Updated by vo.x (Vit Ondruch) over 5 years ago

Thanks a lot. Can this be backported or not?

#9

Updated by usa (Usaku NAKAMURA) over 5 years ago

  • Backport changed from 2.0.0: UNKNOWN, 2.1: UNKNOWN, 2.2: UNKNOWN to 2.0.0: WONTFIX, 2.1: REQUIRED, 2.2: REQUIRED
#10

Updated by usa (Usaku NAKAMURA) over 5 years ago

  • Backport changed from 2.0.0: WONTFIX, 2.1: REQUIRED, 2.2: REQUIRED to 2.0.0: WONTFIX, 2.1: DONE, 2.2: REQUIRED

ruby_2_1 r50574 merged revision(s) 50185.

Updated by nagachika (Tomoyuki Chikanaga) over 5 years ago

  • Backport changed from 2.0.0: WONTFIX, 2.1: DONE, 2.2: REQUIRED to 2.0.0: WONTFIX, 2.1: DONE, 2.2: DONE

Backported into ruby_2_2 branch at r50622.

Also available in: Atom PDF