Project

General

Profile

Bug #15284

Unintentional warnings with node.h

Added by hsbt (Hiroshi SHIBATA) 14 days ago. Updated 9 days ago.

Status:
Closed
Priority:
Normal
Target version:
-
[ruby-core:89722]

Description

Recently, I got the following warnings with build time.

parse.c:4720:14: warning: incompatible pointer types passing 'FILE *' (aka 'struct __sFILE *') to parameter of type 'struct parser_params *' [-Wincompatible-pointer-types]
  YYFPRINTF (yyo, "%s %s (",
             ^~~
../node.h:437:57: note: passing argument to parameter 'parser' here
PRINTF_ARGS(void rb_parser_printf(struct parser_params *parser, const char *fmt, ...), 2, 3);
                                                        ^
parse.c:4724:14: warning: incompatible pointer types passing 'FILE *' (aka 'struct __sFILE *') to parameter of type 'struct parser_params *' [-Wincompatible-pointer-types]
  YYFPRINTF (yyo, ": ");
             ^~~
../node.h:437:57: note: passing argument to parameter 'parser' here
PRINTF_ARGS(void rb_parser_printf(struct parser_params *parser, const char *fmt, ...), 2, 3);
                                                        ^
parse.c:4726:14: warning: incompatible pointer types passing 'FILE *' (aka 'struct __sFILE *') to parameter of type 'struct parser_params *' [-Wincompatible-pointer-types]
  YYFPRINTF (yyo, ")");
             ^~~
../node.h:437:57: note: passing argument to parameter 'parser' here
PRINTF_ARGS(void rb_parser_printf(struct parser_params *parser, const char *fmt, ...), 2, 3);

Maybe, It caused by bison version.

> bison --version
bison (GNU Bison) 3.2

Related issues

Related to Ruby trunk - Bug #15297: Appveyor - test-all failures & build warnings - bison 3.1 vs 3.2 ?Closed

Associated revisions

Revision 6a85c2a5
Added by nobu (Nobuyoshi Nakada) 9 days ago

Fix for bison 3.2 [Bug #15284]

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@65667 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 65667
Added by nobu (Nobuyoshi Nakada) 9 days ago

Fix for bison 3.2 [Bug #15284]

History

#1 Updated by nobu (Nobuyoshi Nakada) 9 days ago

  • Related to Bug #15297: Appveyor - test-all failures & build warnings - bison 3.1 vs 3.2 ? added

#2 Updated by nobu (Nobuyoshi Nakada) 9 days ago

  • Status changed from Assigned to Closed

Applied in changeset trunk|r65667.


Fix for bison 3.2 [Bug #15284]

#3 [ruby-core:89770] Updated by yui-knk (Kaneko Yuichiro) 9 days ago

JFYI: It seems this commit on bison http://git.savannah.gnu.org/cgit/bison.git/commit/?id=e7b709ab0b00244f87f53e60bc2d0ad6b32f0c23 changed yyoutput to yyo. And this change on bison has been introduced to version 3.2.

Ref: http://lists.gnu.org/archive/html/bison-patches/2018-10/msg00083.html

#4 Updated by nobu (Nobuyoshi Nakada) 9 days ago

  • Backport changed from 2.3: UNKNOWN, 2.4: UNKNOWN, 2.5: UNKNOWN to 2.3: REQUIRED, 2.4: REQUIRED, 2.5: REQUIRED

Also available in: Atom PDF