Project

General

Profile

Bug #15520

[patch] configure should refuse to build with jemalloc when headers are missing

Added by mistydemeo (Misty De Meo) over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.7.0dev (2019-01-10 fix_jemalloc_i.. 66768) [x86_64-darwin18]
[ruby-core:90964]

Description

When the --with-jemalloc option is passed, the configure script will correctly fail with an error if the library is missing. However, if the library is present and headers are missing, configure will succeed and allow the build to proceed. The actual build is unlikely to succeed in this case since the functions won't be defined.

Steps to reproduce:

  1. Install jemalloc.
  2. Delete jemalloc's headers.
  3. Run ./configure --with-jemalloc &&is make

Expected behaviour:
configure fails because the requested jemalloc's headers are missing

Actual behaviour:
configure succeeds. On macOS, the build then fails with the following:

compiling gc.c
gc.c:7955:12: error: implicit declaration of function 'malloc_usable_size' is invalid in C99
      [-Werror,-Wimplicit-function-declaration]
    return malloc_usable_size(ptr);
           ^
gc.c:7955:12: note: did you mean 'malloc_good_size'?
/Library/Developer/CommandLineTools/SDKs/MacOSX10.14.sdk/usr/include/malloc/malloc.h:134:15: note:
      'malloc_good_size' declared here
extern size_t malloc_good_size(size_t size);
              ^
1 error generated.
make: *** [gc.o] Error 1

The attached patch fixes this by ensuring that configure fails if --with-jemalloc is passed but the headers are missing in the same way that it will fail if the library is missing.

This patch is against trunk. I've also reproduced it in several previous versions of Ruby.


Files

Updated by shevegen (Robert A. Heiler) over 1 year ago

The actual build is unlikely to succeed in this case since the functions won't be defined.

Agreed, makes sense to me. I remember that I may run into similar situations every now
and then when I e. g. wish to upgrade some program manually on my own but may have
forgotten to remove all old parts of that program (e. g. under the /usr/ hierarchy). I don't
know if this applies to Mac but on Linux I remember similar situations here and there.

#2

Updated by nobu (Nobuyoshi Nakada) over 1 year ago

  • Status changed from Open to Closed

Applied in changeset trunk|r66779.


configure: refuse to build with jemalloc when header is missing

[ruby-core:90964] [Bug #15520]

Freom: Misty De Meo mistydemeo@github.com

Updated by mistydemeo (Misty De Meo) over 1 year ago

Thanks for the quick response! Could you backport this to the active backport branches, too?

#4

Updated by nagachika (Tomoyuki Chikanaga) over 1 year ago

  • Backport changed from 2.4: UNKNOWN, 2.5: UNKNOWN, 2.6: UNKNOWN to 2.4: REQUIRED, 2.5: REQUIRED, 2.6: REQUIRED

Updated by naruse (Yui NARUSE) over 1 year ago

  • Backport changed from 2.4: REQUIRED, 2.5: REQUIRED, 2.6: REQUIRED to 2.4: REQUIRED, 2.5: REQUIRED, 2.6: DONE

ruby_2_6 r66852 merged revision(s) 66779.

Updated by nagachika (Tomoyuki Chikanaga) over 1 year ago

  • Backport changed from 2.4: REQUIRED, 2.5: REQUIRED, 2.6: DONE to 2.4: REQUIRED, 2.5: DONE, 2.6: DONE

ruby_2_5 r67240 merged revision(s) 66779.

Also available in: Atom PDF