Project

General

Profile

Actions

Bug #17582

closed

Build failure with bison-3.7.5

Added by hsbt (Hiroshi SHIBATA) 11 months ago. Updated 10 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:102244]

Description

I got the following error with bison 3.7.5 provided by homebrew on macOS Catalina.

parse.y:13337:5: error: implicit declaration of function 'YYUSE' is invalid in C99 [-Werror,-Wimplicit-function-declaration]
    YYUSE(p);
    ^
1 error generated.
make: *** [parse.o] Error 1
make: *** Waiting for unfinished jobs....

I could build with bison-2.3 provided by system toolchain by macOS.

Actions #1

Updated by nobu (Nobuyoshi Nakada) 11 months ago

  • Status changed from Open to Closed

Applied in changeset git|b091889ed67f278b1652ddde88596e2160d5aef0.


Removed YYUSE [Bug #17582]

Although it was used just to suppress an "unsed argument" warning
in the same manner as other bison-provided functions, it has been
dropped since Bision 3.7.5. And we always suppress that
warnings.

Updated by hsbt (Hiroshi SHIBATA) 11 months ago

  • Backport changed from 2.5: UNKNOWN, 2.6: UNKNOWN, 2.7: UNKNOWN, 3.0: UNKNOWN to 2.5: UNKNOWN, 2.6: REQUIRED, 2.7: REQUIRED, 3.0: REQUIRED

Thanks nobu. I confirmed to build with bison-3.7.5

Updated by nagachika (Tomoyuki Chikanaga) 10 months ago

  • Backport changed from 2.5: UNKNOWN, 2.6: REQUIRED, 2.7: REQUIRED, 3.0: REQUIRED to 2.5: UNKNOWN, 2.6: REQUIRED, 2.7: DONE, 3.0: REQUIRED

ruby_2_7 7332b3f367ce61089bf571fa1c458fde06a11eab merged revision(s) b091889ed67f278b1652ddde88596e2160d5aef0.

Actions #4

Updated by usa (Usaku NAKAMURA) 10 months ago

  • Backport changed from 2.5: UNKNOWN, 2.6: REQUIRED, 2.7: DONE, 3.0: REQUIRED to 2.5: DONTNEED, 2.6: DONTNEED, 2.7: DONE, 3.0: REQUIRED

Updated by naruse (Yui NARUSE) 10 months ago

  • Backport changed from 2.5: DONTNEED, 2.6: DONTNEED, 2.7: DONE, 3.0: REQUIRED to 2.5: DONTNEED, 2.6: DONTNEED, 2.7: DONE, 3.0: DONE

ruby_3_0 e9843cdaee26387310384fa0a1d43d450b017350 merged revision(s) b091889ed67f278b1652ddde88596e2160d5aef0.

Actions

Also available in: Atom PDF