Bug #3353

Building 32-bit only on Snow Leopard (dylib failed to build)

Added by Bryan Ross almost 4 years ago. Updated 11 months ago.

[ruby-core:30455]
Status:Closed
Priority:Low
Assignee:Kenta Murata
Category:build
Target version:-
ruby -v:1.9.1 Backport:

Description

=begin
Okay, I know this isn't all THAT helpful, but I was trying to build ruby 1.9.1 on Snow Leopard, but 32-bit only. I had CFLAGS, LDFLAGS, CXXFLAGS, and DLDFLAGS all set to '-arch i386'

Everything would be fine, all *.o files would be built i386, but when it came time to create libruby.1.9.1.dylib, the -arch i386 flag was not present. I'm no autoconf genius, so I have absolutely NO idea how to patch this. But all I did was re-run the failing command and manually added the -arch i386 command, and it worked.

A minor point, but kind of annoying nonetheless.

I have attached the relevant output of 'make'.
=end

ruby-build.txt Magnifier (7.77 KB) Bryan Ross, 05/27/2010 06:56 PM

History

#1 Updated by Yuki Sonoda almost 4 years ago

  • Assignee set to Yuki Sonoda

=begin

=end

#2 Updated by Shyouhei Urabe over 3 years ago

  • Status changed from Open to Assigned

=begin

=end

#3 Updated by Randy Parker over 2 years ago

This bug continues to prevent 32-bit builds on OSX Lion in 1.9.3 preview1.

It blocks use of the 32-bit version of Oracle InstantClient, which is the only InstantClient that works on OSX 10.7 Lion.

#4 Updated by Yui NARUSE over 2 years ago

  • Project changed from Backport191 to ruby-trunk
  • Category changed from build to build

#5 Updated by Yui NARUSE over 2 years ago

  • Assignee changed from Yuki Sonoda to Kenta Murata

#6 Updated by Nobuyoshi Nakada over 2 years ago

  • Status changed from Assigned to Feedback

Try --with-arch=x86_64 option.

#7 Updated by Nobuyoshi Nakada over 2 years ago

Sorry, it should be --with-arch=i386, of course.

#8 Updated by Randy Parker over 2 years ago

Do you mean just "-arch=i386" ? I have tried that as a directive in .rvmrc. It results in the build failure originally described by Bryan Ross. Replacing "-arch=i386' with '--with-arch=i386" as an rvm directive causes immediate build abort.

Where should the "--with-arch=i386" be specified if not in .rvmrc?

#9 Updated by Yusuke Endoh over 1 year ago

  • Status changed from Feedback to Assigned

"--with-arch=i386" should be specified in ./configure, I guess.

Mrkn, do you know the status of this issue? Do you think this issue should be fixed before 2.0.0?

Yusuke Endoh mame@tsg.ne.jp

#10 Updated by Kenta Murata 11 months ago

  • Status changed from Assigned to Closed

I maintain the CI for 32-bit OS X.
You can check the result of it in http://rubyci.org/

Also available in: Atom PDF