Bug #9374

[PATCH] ext/json: objects depend on $(ruby_headers)

Added by Eric Wong about 1 year ago. Updated about 1 year ago.

[ruby-core:59609]
Status:Closed
Priority:Normal
Assignee:Nobuyoshi Nakada
ruby -v:ruby 2.2.0dev (2014-01-07 trunk 44513) [x86_64-linux] Backport:1.9.3: DONE, 2.0.0: DONE, 2.1: DONE

Description

We must rebuild the extension on Ruby ABI changes, otherwise
we'll get mysterious test failures

I encountered this when switching between cachelined and normal trunk.

pull request:

The following changes since commit 2030e19a04e92ee3d4f605c15af0e1f115732813:

  • 2014-01-07 (2014-01-06 19:38:25 +0000)

are available in the git repository at:

git://bogomips.org/ruby.git json-depend

for you to fetch changes up to 93ccc7f9f1feabc95231ee8bc39945f7e4eb432d:

ext/json: objects depend on $(ruby_headers) (2014-01-06 23:32:47 +0000)


Eric Wong (1):
ext/json: objects depend on $(ruby_headers)

ext/json/generator/depend | 1 +
ext/json/parser/depend | 1 +
2 files changed, 2 insertions(+)

0001-ext-json-objects-depend-on-ruby_headers.patch Magnifier (946 Bytes) Eric Wong, 01/07/2014 09:48 AM

Associated revisions

Revision 44514
Added by Aman Gupta about 1 year ago

ext/json: objects depend on $(ruby_headers)

  • ext/json/generator/depend: add build dependencies for json extension Patch by normalperson (Eric Wong) [Bug #9374]
  • ext/json/parser/depend: ditto

Revision 44514
Added by Aman Gupta about 1 year ago

ext/json: objects depend on $(ruby_headers)

  • ext/json/generator/depend: add build dependencies for json extension Patch by normalperson (Eric Wong) [Bug #9374]
  • ext/json/parser/depend: ditto

History

#1 Updated by Aman Gupta about 1 year ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r44514.
Eric, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


ext/json: objects depend on $(ruby_headers)

  • ext/json/generator/depend: add build dependencies for json extension Patch by normalperson (Eric Wong) [Bug #9374]
  • ext/json/parser/depend: ditto

#2 Updated by Usaku NAKAMURA about 1 year ago

  • Backport changed from 1.9.3: UNKNOWN, 2.0.0: UNKNOWN, 2.1: UNKNOWN to 1.9.3: REQUIRED, 2.0.0: REQUIRED, 2.1: REQUIRED

#3 Updated by Usaku NAKAMURA about 1 year ago

  • Backport changed from 1.9.3: REQUIRED, 2.0.0: REQUIRED, 2.1: REQUIRED to 1.9.3: DONE, 2.0.0: REQUIRED, 2.1: REQUIRED

backported into ruby_1_9_3 at r44947.

#4 Updated by Tomoyuki Chikanaga about 1 year ago

  • Backport changed from 1.9.3: DONE, 2.0.0: REQUIRED, 2.1: REQUIRED to 1.9.3: DONE, 2.0.0: DONE, 2.1: REQUIRED

r44514 was backported to ruby_2_0_0 at r45009.

#5 Updated by Yui NARUSE about 1 year ago

  • Backport changed from 1.9.3: DONE, 2.0.0: DONE, 2.1: REQUIRED to 1.9.3: DONE, 2.0.0: DONE, 2.1: DONE

r45123

Also available in: Atom PDF