Project

General

Profile

Actions

Feature #9420

closed

warn and puts should be atomic

Added by normalperson (Eric Wong) over 8 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
[ruby-core:<unknown>]

Description

Since we added use of writev in r44618, we should make warn/puts atomic.
It would make development of multiprocess/multithreaded processes easier,
I think it was intended to be atomic based on old comments in io.c:

-       /*
-        * xxx: use writev to avoid double write if available
-        * writev may help avoid context switch between "a" and "\n" in
-        * STDERR.puts "a" [ruby-dev:25080] (rebroken since native threads
-        * introduced in 1.9)
-        */

Related issues 2 (0 open2 closed)

Related to Ruby master - Feature #9323: IO#writevClosedGlass_saga (Masaki Matsushita)Actions
Has duplicate Ruby master - Feature #14042: IO#puts: use writev if availableClosedActions
Actions

Also available in: Atom PDF