Project

General

Profile

Bug #9591

io-console versioning

Added by vo.x (Vit Ondruch) over 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
ruby -v:
ruby 2.1.1p76 (2014-02-24 revision 45161) [x86_64-linux]
[ruby-core:61291]

Description

io-console has changed between 2.1.0 and 2.1.1 [1] so it should be reflected in its version number.

[1] https://github.com/ruby/ruby/compare/v2_1_0...v2_1_1#diff-16

Associated revisions

Revision 85f33396
Added by nagachika (Tomoyuki Chikanaga) over 4 years ago

merge revision(s) r48878: [Backport #9591]

    io-console.gemspec: bump up

    * ext/io/console/io-console.gemspec: bump up to 0.4.3.

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_1@50127 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 50127
Added by nagachika (Tomoyuki Chikanaga) over 4 years ago

merge revision(s) r48878: [Backport #9591]

io-console.gemspec: bump up

* ext/io/console/io-console.gemspec: bump up to 0.4.3.

History

Updated by nobu (Nobuyoshi Nakada) over 5 years ago

BTW, I've forgotten the passphrace of the PEM, so I can't make new gem file now.

Updated by vo.x (Vit Ondruch) almost 5 years ago

This is still/again issue for Ruby 2.2. There are changes in io-console but its version does not reflect them. Could you please make the io-console versioning reliable and useful? Thanks

BTW this is concern for BigDecimal as well ...

Updated by naruse (Yui NARUSE) over 4 years ago

bumped at r48878.

BigDecimal's maintainer is mrkn, and create another ticket.

Updated by hsbt (Hiroshi SHIBATA) over 4 years ago

  • Status changed from Open to Closed
  • Backport changed from 1.9.3: UNKNOWN, 2.0.0: UNKNOWN, 2.1: UNKNOWN to 1.9.3: DONTNEED, 2.0.0: REQUIRED, 2.1: REQUIRED
#5

Updated by nagachika (Tomoyuki Chikanaga) over 4 years ago

  • Backport changed from 1.9.3: DONTNEED, 2.0.0: REQUIRED, 2.1: REQUIRED to 1.9.3: DONTNEED, 2.0.0: DONE, 2.1: REQUIRED

Backported into ruby_2_1 branch at r50127.

#6

Updated by usa (Usaku NAKAMURA) over 4 years ago

  • Backport changed from 1.9.3: DONTNEED, 2.0.0: DONE, 2.1: REQUIRED to 1.9.3: DONTNEED, 2.0.0: REQUIRED, 2.1: DONE

Also available in: Atom PDF