Project

General

Profile

Backport #1225

Curses::getmouse

Added by sz (Sandor Szücs) over 10 years ago. Updated over 8 years ago.

Status:
Assigned
Priority:
Normal
[ruby-core:22592]

Description

=begin
Hi Core!

To reproduce, try:
$ ruby19 -rcurses -e 'Curses::getmouse'

Command output is attached.
=end


Files

curses_bug (1.85 KB) curses_bug sz (Sandor Szücs), 02/28/2009 10:06 PM

History

#1

Updated by ba (Alexander Beisig) over 10 years ago

=begin
Sandor Szücs schrieb:

Bug #1225: Curses::getmouse
http://redmine.ruby-lang.org/issues/show/1225

Author: Sandor Szücs
Status: Open, Priority: Normal
ruby -v: ruby 1.9.2dev (2009-02-26 trunk 22651) [i386-darwin9.6.0]

Hi Core!

To reproduce, try:
$ ruby19 -rcurses -e 'Curses::getmouse'

Command output is attached.

I too noticed that the NCurses mouse functions are quite unstable if
called before initscr(), so it's probably a bug in the NCurses library.
This particular example doesn't crash for me on Linux, but that's
probably just a coincidence.

Alex

=end

#2

Updated by marcandre (Marc-Andre Lafortune) almost 10 years ago

  • Category set to lib
  • Status changed from Open to Closed

=begin
Fixed in r25267 & r25269.

This is not a ncurses library bug, since it states that initscr() must be called before any other function of the lib. Many functions of Curses made sure that the lib was initialized, but many didn't (including getmouse). Other functions (Curses::can_change_colors?, standout, etc...) also crashed (on my old PowerBook on leopard, never on my mac pro running snow leopard).

I am unsure as to why the library is not inited when 'curses' is required, so I just added the calls to all functions that needed it.
=end

#3

Updated by shyouhei (Shyouhei Urabe) over 9 years ago

  • Status changed from Closed to Assigned
  • Assignee set to wyhaines (Kirk Haines)

=begin
This issue also affects 1.8.6, meseems.
=end

#4

Updated by tad (Tadashi Saito) over 9 years ago

=begin
Also 1.9.1.
=end

Also available in: Atom PDF