Project

General

Profile

Actions

Bug #14409

closed

インストール手順の改善

Added by Reetok (Reetok Nino) over 3 years ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Target version:
-
ruby -v:
trunk(2.6.0)
[ruby-dev:50440]
Tags:

Description

以下の2つのインストール手順の部分を改善した方が良いと思いました。

  1. ./configureの生成に必要なautoconfのバージョンを指定するべき
    • 2.68以降
  2. config.hとMakefileの生成に必要なRubyのバージョンを指定するべき
    • 少なくともto_pathが実装されているバージョン

環境

$ cat /etc/redhat-release
CentOS release 6.8 (Final)
$ uname -a
Linux kogeki 2.6.32-642.el6.x86_64 #1 SMP Tue May 10 17:27:01 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

./configureの生成に必要なautoconfのバージョン

README.mdのHow to compile and installの 2つ目の手順にて autoconf を実行したところ、以下のエラーが発生しました。

$ autoconf
configure.ac:7: error: Autoconf version 2.67 or higher is required
configure.ac:7: the top level
autom4te: /usr/bin/m4 failed with exit status: 63

2.67以上にのみ対応しているということだったので,このサイトを参考に,2.68を導入したところ,./configureが正常終了しました。
以上より,autoconfのバージョンを指定すべきだと考えます。

config.hとMakefileの生成に必要なRubyのバージョン

README.mdHow to compile and installの3つめの手順にて,以下のエラーが発生しました。

$ ./configure
checking for ruby... false
configure: error: cannot run /bin/sh tool/config.sub

rubyが必要だったということで,sudo yum install rubyでrubyを入れ,再度実行したところNoMethodError'to_path'が発生しました。
to_pathが実装されているRuby(2.4.3)を使用したところ,成功しました。
以上より,config.hとMakefileの生成に必要なrubyのバージョンを指定すべきだと考えます。

Actions #1

Updated by Reetok (Reetok Nino) over 3 years ago

  • ruby -v set to trunk(2.6.0)

Updated by Reetok (Reetok Nino) over 3 years ago

Ruby1.8.7で./configureの実行結果

checking for ruby... /usr/bin/ruby
downloading config.guess ... done
tool/downloader.rb:212:in `download': failed to download config.guess (RuntimeError)
NoMethodError: undefined method `to_path' for #<Pathname:tool/config.guess>: https://raw.githubusercontent.com/gcc-mirror/gcc/master/config.guess
    from tool/downloader.rb:54:in `download'
    from tool/downloader.rb:344
    from tool/downloader.rb:328:in `each'
    from tool/downloader.rb:328
configure: error: cannot run /bin/sh tool/config.sub
Actions #3

Updated by okkez (okkez _) over 3 years ago

  • Description updated (diff)

Updated by okkez (okkez _) over 3 years ago

desription のフォーマットがおかしかったのを修正しました。

Updated by nobu (Nobuyoshi Nakada) over 3 years ago

Pathname#to_path は1.9.3以降ですね。
また、autoconfやrubyが必要になるのはrepositoryから直接作る場合なので、tarballから作る場合では必要な手順が変わります。
その点も明確にしたほうがいいでしょう。

Updated by hsbt (Hiroshi SHIBATA) over 3 years ago

  • Assignee set to hsbt (Hiroshi SHIBATA)
  • Status changed from Open to Assigned

bison や gcc などまずは最小限必要なコンポーネントを洗い出した上で要求バージョンを明示して行くと良さそうに思いました。

ひとまず私の方で進めます。

Updated by jeremyevans0 (Jeremy Evans) about 1 month ago

I believe this is asking for a section on build requirements to be added to the README, which seems useful for me. I added a pull request for this: https://github.com/ruby/ruby/pull/4582. I'm not sure if there are missing requirements, or the minimum versions of bison or automake that we support, so additional review would be helpful.

Actions #8

Updated by jeremyevans (Jeremy Evans) about 1 month ago

  • Status changed from Assigned to Closed

Applied in changeset git|1de063a10b5c5c71d0602c961862b8396702dbb1.


Add section on build requirements to the README

I'm not sure that this is section is complete (may be missing
requirements), or accurate (minimum automake or bison versions
may not be correct). However, I think it's useful, and we can
adjust it in the future to add requirements or adjust
requirement versions.

Fixes [Bug #14409]

Actions

Also available in: Atom PDF