Project

General

Profile

Actions

Feature #18839

closed

Drop support for gcc 3

Added by nobu (Nobuyoshi Nakada) 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:108998]

Description

Currently we require version 3 or newer when using gcc, but no CI for gcc 3.
Do we still need to support gcc 3?
https://github.com/ruby/ruby/pull/6037

Besides, I suspect we can drop old versions of gcc and clang more.

Actions #1

Updated by nobu (Nobuyoshi Nakada) 5 months ago

  • Description updated (diff)

Updated by byroot (Jean Boussier) 5 months ago

Out of curiosity I went to check a few dates:

  • First GCC 3.x release: June 18, 2001
  • Last GCC 3.x release: March 06, 2006
  • That was the default compiler up to RHEL4, which is out of support since November 30, 2020.

So IMHO, if even Red Hat no longer supports it, it's probably fine to drop it.

Updated by shyouhei (Shyouhei Urabe) 5 months ago

+1, it's hard to have a working gcc-3 environment nowadays.

Actions #4

Updated by nobu (Nobuyoshi Nakada) 5 months ago

  • Description updated (diff)

Updated by hsbt (Hiroshi SHIBATA) 5 months ago

+1

The gcc version of CentOS/RHEL 7 that is our oldest supported Linux distribution is gcc-4.8.5-44.el7.x86_64.rpm.

Updated by matz (Yukihiro Matsumoto) 5 months ago

Go. Probably no one is really using gcc3.x.

Matz.

Actions #7

Updated by nobu (Nobuyoshi Nakada) 5 months ago

  • Status changed from Open to Closed

Applied in changeset git|ec5c56412f0b67845b42acec06cbd1d341896f25.


[Feature #18839] Drop support for gcc 3 [ci skip]

Actions

Also available in: Atom PDF

Like0
Like0Like0Like0Like0Like0Like0Like0