Project

General

Profile

Bug #5339

ERB generates extra newlines on Windows

Added by DNNX (Viktar Basharymau) over 7 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Target version:
ruby -v:
ruby 1.9.2p290 (2011-07-09) [i386-mingw32]
[ruby-core:39625]

Description

Steps to reproduce:

(1) Create files from this gist: https://gist.github.com/1226780.
(2) Run ruby erbug.rb.
(3) If you're on windows, you'll see something like

  • 1

    • 2
    • 3 Otherwise, it will be like this:
  • 1

    • 2
    • 3

This bug also affects bundler gem (see https://github.com/carlhuda/bundler/issues/1371).

Associated revisions

Revision b82ed2ce
Added by k0kubun (Takashi Kokubun) almost 2 years ago

erb.rb: Allow explicit trimming carriage return

when trim_mode is "-", for Windows environments.

[ruby-core:39625] [Bug #5339]

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@58825 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 58825
Added by k0kubun (Takashi Kokubun) almost 2 years ago

erb.rb: Allow explicit trimming carriage return

when trim_mode is "-", for Windows environments.

[ruby-core:39625] [Bug #5339]

Revision 58825
Added by k0kubun (Takashi Kokubun) almost 2 years ago

erb.rb: Allow explicit trimming carriage return

when trim_mode is "-", for Windows environments.

[ruby-core:39625] [Bug #5339]

Revision 58825
Added by k0kubun (Takashi Kokubun) almost 2 years ago

erb.rb: Allow explicit trimming carriage return

when trim_mode is "-", for Windows environments.

[ruby-core:39625] [Bug #5339]

Revision 58826
Added by k0kubun (Takashi Kokubun) almost 2 years ago

erb.rb: Allow trimming CR in all trim_modes

to unify a behavior with r58823 and r58825.

Revision 17b77906
Added by usa (Usaku NAKAMURA) over 1 year ago

merge revision(s) 58825,58826: [Backport #5339]

erb.rb: Allow explicit trimming carriage return

when trim_mode is "-", for Windows environments.

[ruby-core:39625] [Bug #5339]
erb.rb: Allow trimming CR in all trim_modes

to unify a behavior with r58823 and r58825.

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_3@59226 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 59226
Added by usa (Usaku NAKAMURA) over 1 year ago

merge revision(s) 58825,58826: [Backport #5339]

erb.rb: Allow explicit trimming carriage return

when trim_mode is "-", for Windows environments.

[ruby-core:39625] [Bug #5339]
erb.rb: Allow trimming CR in all trim_modes

to unify a behavior with r58823 and r58825.

Revision 420151cf
Added by nagachika (Tomoyuki Chikanaga) over 1 year ago

merge revision(s) 58825,58826: [Backport #5339]

erb.rb: Allow explicit trimming carriage return

when trim_mode is "-", for Windows environments.

[ruby-core:39625] [Bug #5339]
erb.rb: Allow trimming CR in all trim_modes

to unify a behavior with r58823 and r58825.

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_4@59301 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 59301
Added by nagachika (Tomoyuki Chikanaga) over 1 year ago

merge revision(s) 58825,58826: [Backport #5339]

erb.rb: Allow explicit trimming carriage return

when trim_mode is "-", for Windows environments.

[ruby-core:39625] [Bug #5339]
erb.rb: Allow trimming CR in all trim_modes

to unify a behavior with r58823 and r58825.

History

Updated by ko1 (Koichi Sasada) about 7 years ago

  • Category set to lib
  • Status changed from Open to Assigned
  • Assignee set to seki (Masatoshi Seki)

Updated by hsbt (Hiroshi SHIBATA) almost 2 years ago

  • Target version set to 2.5
  • Assignee changed from seki (Masatoshi Seki) to k0kubun (Takashi Kokubun)
#3

Updated by k0kubun (Takashi Kokubun) almost 2 years ago

  • Is duplicate of Bug #11464: ERB trimming doesn't trim carriage returns added
#4

Updated by k0kubun (Takashi Kokubun) almost 2 years ago

  • Is duplicate of deleted (Bug #11464: ERB trimming doesn't trim carriage returns)
#5

Updated by k0kubun (Takashi Kokubun) almost 2 years ago

  • Status changed from Assigned to Closed

Applied in changeset trunk|r58825.


erb.rb: Allow explicit trimming carriage return

when trim_mode is "-", for Windows environments.

[ruby-core:39625] [Bug #5339]

#6

Updated by nagachika (Tomoyuki Chikanaga) almost 2 years ago

  • Backport changed from 2.2: UNKNOWN, 2.3: UNKNOWN, 2.4: UNKNOWN to 2.2: REQUIRED, 2.3: REQUIRED, 2.4: REQUIRED

Updated by usa (Usaku NAKAMURA) over 1 year ago

  • Backport changed from 2.2: REQUIRED, 2.3: REQUIRED, 2.4: REQUIRED to 2.2: REQUIRED, 2.3: DONE, 2.4: REQUIRED

ruby_2_3 r59226 merged revision(s) 58825,58826.

Updated by nagachika (Tomoyuki Chikanaga) over 1 year ago

  • Backport changed from 2.2: REQUIRED, 2.3: DONE, 2.4: REQUIRED to 2.2: REQUIRED, 2.3: DONE, 2.4: DONE

ruby_2_4 r59301 merged revision(s) 58825,58826.

Also available in: Atom PDF