misc #8741

email notification on bugs.ruby-lang.org is broken

Added by First Last 9 months ago. Updated 3 months ago.

[ruby-core:56407]
Status:Closed
Priority:Normal
Assignee:Hiroshi SHIBATA
Category:-
Target version:-

Description

I don't know where else to report this

History

#1 Updated by Henrik Hodne 9 months ago

This is a little hard to debug. What do you mean by "broken"? Do you not receive them? Do you only receive some? Are they garbled? I get notifications just fine, so they can't be completely broken.

#2 Updated by First Last 9 months ago

henrikhodne (Henrik Hodne) wrote:

This is a little hard to debug. What do you mean by "broken"? Do you not receive them? Do you only receive some? Are they garbled? I get notifications just fine, so they can't be completely broken.

I get no notifications to the gmail address configured on this account. Explicitly watching bugs does not help. They are not in spam nor otherwise filtered. There's nothing wrong with the gmail account, I do get notifications from other services.

The email notification settings are: "only for things I watch or am involved in", "I don't want to be notified of changes I make myself"

#3 Updated by Vit Ondruch 9 months ago

I complained about the same a while ago (ruby-core:52371) but nothing changed :/ I also opened ticket for ruby-lang.org redmine (https://github.com/asakusarb/redmine4ruby-lang/issues/28) but that remains without response as well.

#4 Updated by Hiroshi SHIBATA 5 months ago

  • Assignee set to Hiroshi SHIBATA

I'm sorry for your inconvenience experience. we rebuild our mailing list system at Aug, because of system failure.
Probably mailing-list is rolling back to spring this year from Aug. Please re-register it.

#5 Updated by Hiroshi SHIBATA 5 months ago

  • Status changed from Open to Closed

#6 Updated by Michal Papis 5 months ago

Please explain what does it mean re-register? I have heard from https://bugs.ruby-lang.org/users/7549 that he also does not get the notifications and he was registered on 10/25/2013 which is after the mentioned event.

#7 Updated by Gabriele Giacone 5 months ago

I registered few weeks ago and didn't receive any notification neither from bugs i filed (#8937, #8990, #8999, #9000) nor from ones I was watching (#8741).
Please reopen it.

(same issue at https://github.com/asakusarb/redmine4ruby-lang/issues/28)

#8 Updated by First Last 5 months ago

this is not fixed, I haven't received any notifications from this bug.

I too don't understand what is being suggested by "re-register". It sounds like you are talking about unsubscribing an resubscribing to a mailing list, presumably ruby-core?, but I am not on ruby-core, and this bug is not about ruby-core or any other list, it's about bugs.ruby-lang.org accounts.

#9 Updated by Eric Wong 5 months ago

I cannot fix bugs.ruby-lang.org, but as a workaround I suggest
subscribing to ruby-core anyways. ruby-core is basically an
email gateway to bugs.ruby-lang.org (which is good for people like
me who hate using web browsers).

#10 Updated by First Last 5 months ago

Receiving all of ruby-core is not the same as following certain specific issues that one reported or is interested in.

It's possible to subscribe to specific ruby-core threads on ruby-forum.com.

However, what is the problem with fixing email notification on bugs.ruby-lang.org? This issue is 4 months old and the underlying problem, even older.

#11 Updated by Eric Wong 5 months ago

I should clarify I am not an admin and have no access/perms to fix this.

However, running an automatic mail notifier can be difficult and
time-consuming because of bounce/invalid-mail processing and the
possibility of ending up on antispam blacklists. So maybe that's
why this feature does not work.

Also, I notice there is an issue-specific Atom feed for each issue.
Perhaps following these feeds makes life easier?
e.g. https://bugs.ruby-lang.org/issues/8741.atom

#12 Updated by Michal Papis 5 months ago

Maybe it is all about missing SPF record for the server bugs.ruby-lang.org to send emails in name of ruby-lang.org => https://support.google.com/a/answer/33786

#13 Updated by First Last 5 months ago

Why is this closed?

#14 Updated by Hiroshi SHIBATA 5 months ago

  • Status changed from Closed to Feedback

ok, I restart to investigation.

#15 Updated by Yui NARUSE 5 months ago

Our redmine's notification seems buggy.
Contribution is welcome.
https://github.com/asakusarb/redmine4ruby-lang/issues/28

#16 Updated by Alexey Muranov 5 months ago

A have newer received any email notification, i do not know why.

#17 Updated by Hiroshi SHIBATA 3 months ago

  • Status changed from Feedback to Closed

#18 Updated by First Last 3 months ago

This is not resolved

#19 Updated by Michal Papis 3 months ago

I can confirm this still does not work - I did not get notification for last comment and neither closing the ticket.

#20 Updated by Michal Papis 3 months ago

but I got notification about my last message, removed the flag I don't want to be notified of changes that I make myself from account settings and trying again :)

Also available in: Atom PDF