Project

General

Profile

Feature #9278

Magic comment "immutable: string" makes "literal".freeze the default for that file

Added by colindkelley (Colin Kelley) almost 7 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
[ruby-core:59260]

Description

Building on https://bugs.ruby-lang.org/issues/9042, this pull request adds the magic comment # -- immutable: string -- that implies .freeze on every string literal in the file. To get a mutable string in a file that starts with the magic comment, use String.new or ''.dup.

Here is a corresponding github pull request:

https://github.com/ruby/ruby/pull/487

For more details, background, and rationale, please see this blog post:

http://development.invoca.com/magic-comment-immutable-string-makes-ruby-2-1s-literal-freeze-optimization-the-default/

Related issues

Is duplicate of Ruby master - Feature #8976: file-scope freeze_string directiveClosedmatz (Yukihiro Matsumoto)Actions

Also available in: Atom PDF