Project

General

Profile

Actions

Misc #19040

closed

DevMeeting-2022-10-20

Added by mame (Yusuke Endoh) 2 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
[ruby-core:110211]

Description

The next dev meeting

Date: 2022/10/20 13:00-17:00 (JST)
Log: https://github.com/ruby/dev-meeting-log/blob/master/DevMeeting-2022-10-20.md

  • Dev meeting IS NOT a decision-making place. All decisions should be done at the bug tracker.
  • Dev meeting is a place we can ask Matz, nobu, nurse and other developers directly.
  • Matz is a very busy person. Take this opportunity to ask him. If you can not attend, other attendees can ask instead of you (if attendees can understand your issue).
  • We will write a record of the discussion in the file or to each ticket in English.
  • All activities are best-effort (keep in mind that most of us are volunteer developers).
  • The date, time and place of the meeting are scheduled according to when/where we can reserve Matz's time.
  • DO NOT discuss then on this ticket, please.

Call for agenda items

If you have a ticket that you want matz and committers to discuss, please post it into this ticket in the following format:

* [Ticket ref] Ticket title (your name)
  * Comment (A summary of the ticket, why you put this ticket here, what point should be discussed, etc.)

Example:

* [Feature #14609] `Kernel#p` without args shows the receiver (ko1)
  * I feel this feature is very useful and some people say :+1: so let discuss this feature.
  • It is recommended to add a comment by 2022/10/17. We hold a preparatory meeting to create an agenda a few days before the dev-meeting.
  • The format is strict. We'll use this script to automatically create an markdown-style agenda. We may ignore a comment that does not follow the format.
  • Your comment is mandatory. We cannot read all discussion of the ticket in a limited time. We appreciate it if you could write a short summary and update from a previous discussion.

Related issues 1 (1 open0 closed)

Related to Ruby master - Misc #14770: [META] DevelopersMeetingOpenActions
Actions #1

Updated by mame (Yusuke Endoh) 2 months ago

  • Related to Misc #14770: [META] DevelopersMeeting added

Updated by ufuk (Ufuk Kayserilioglu) 2 months ago

  • [Feature #12084] Add Class#attached_object (ufuk)
    • The proposed method returns the object that the receiver is the singleton class for, and raises TypeError if the receiver is not a singleton class.
    • There is one particular use-case for this method when doing introspection, with no good workaround available.
    • PR is ready with tests and documentation and issue already has some :+1:.
    • Should we have this method for Ruby 3.2?

Updated by jeremyevans0 (Jeremy Evans) about 2 months ago

  • [Bug #19033] One-liner pattern match as Boolean arg syntax error (jeremyevans0)
    • m(a in b) is syntax error, similar to how m(a if b) is a syntax error
    • m a in b is a syntax error, but m a if b is not (parsed as m(a) if b)
    • m((a in b)) and m((a if b)) are both valid syntax
    • Should we attempt to support m(a in b), m(a if b), and/or m a in b?
  • [Bug #18998] Kernel#Integer does not convert SimpleDelegator object expectly (jeremyevans0)
    • I think this behavior is expected and not a bug.
    • Should core methods attempt to deal specially with objects using stdlib delegate library?
  • [Bug #18983] Range#size for beginless Range is not nil. (jeremyevans0)
    • (..object).size returns Infinity and (object..).size returns nil for non-numeric objects
    • Should we change (..object).size to return nil instead of Infinity?
  • [Bug #18797] Third argument to Regexp.new is a bit broken (jeremyevans0)
    • This was discussed in the August 2022 developer meeting, but there was confusion about whether the third argument is ignored or used.
    • @matz (Yukihiro Matsumoto) thought the third argument was ignored, but it is used and results in unexpected behavior.
    • Should I update the documentation, or should the third argument be deprecated and removed?

Updated by mame (Yusuke Endoh) about 2 months ago

  • [Bug #19055] Regexp.new(regexp, timeout: nil) is intrupted by Regexp.timeout (mame)
    • How should we design the timeout keyword to express "no timeout"?
    • Regexp.new(str, timeout: nil)
    • Regexp.new(str, timeout: 0)
    • Regexp.new(str, timeout: Float::INFINITY)
    • Regexp.new(str, timeout: :no_timeout)

Updated by ioquatix (Samuel Williams) about 2 months ago

  • [Feature #19056] Introduce Fiber.annotation for attaching messages to fibers.
    • Do we accept the proposed interface?
  • [Feature #19062] Introduce Fiber#locals for shared inheritable state.
    • Related to [Feature #19058] Introduce Fiber.inheritable attributes/variables for dealing with shared state.
    • Can we introduce it?
  • [Feature #19059] Introduce top level module TimeoutError for aggregating various timeout error classes.
  • [Feature #19063] Hash.new with non-value objects should be less confusing.
    • Discuss proposals.

Updated by zverok (Victor Shepelev) about 2 months ago

  • [Feature #19061] Proposal: make a concept of "consuming enumerator" explicit (zverok)
    • Introduce an Enumerator#consuming? method that will allow telling one of the other (and make core enumerators like #each_line properly report they are consuming).
    • Introduce consuming: true parameter for Enumerator.new so it would be easy for user's code to specify the flag
    • Introduce Enumerator#consuming method to produce a consuming enumerator from a non-consuming one

Updated by shioyama (Chris Salzberg) about 2 months ago

  • [Bug #19067] Module methods not usable at toplevel under wrapped script
    • Similar to #18960
    • Based on my understanding of the wrap module, this should work, but top_self currently extends the wrap module.
    • Up to 3.2, wrap was an anonymous module (or no wrap). But now it can be passed in as an argument.
    • This creates some confusion around what methods are callable. I think it should be clarified what is expected.
    • Maybe different handling of boolean/module wrap?

Updated by yui-knk (Kaneko Yuichiro) about 2 months ago

  • [Feature #19068] Upgrades required Bison version for development
    • Change set is only improvement of yydebug option output, however this upgrades required Bison version. Then want to confirm it's acceptable.
  • [Feature #19070] Enhance keep_tokens option for RubyVM::AbstractSyntaxTree parsing methods

Updated by duerst (Martin Dürst) about 2 months ago

  • [Feature #19066] Enable Scorecard Github Action
    • I don't know the details, but at first sight, it seems worth doing
Actions #10

Updated by mame (Yusuke Endoh) about 2 months ago

  • Description updated (diff)
  • Status changed from Open to Closed
Actions

Also available in: Atom PDF

Like0
Like0Like0Like0Like0Like0Like0Like0Like0Like0Like0