Project

General

Profile

Actions

Feature #2635

closed

Unbundle rdoc

Added by naruse (Yui NARUSE) over 12 years ago. Updated about 11 years ago.

Status:
Rejected
Priority:
Normal
Target version:
[ruby-core:27722]

Description

=begin
The rdoc in trunk is outdated and not maintained,
and latest rdoc is in gen.

I think Ruby 1.9 shouldn't bundle such old rdoc.
People who needs rdoc should install from gem.
=end


Related issues 6 (0 open6 closed)

Related to Ruby master - Bug #883: Failure: test_handle_special_CROSSREF_no_underscore(TestRDocMarkupToHtmlCrossref)Closeddrbrain (Eric Hodel)12/15/2008Actions
Related to Ruby master - Bug #1042: RDoc crashes while generating HTML after parsing a Ruby DSL.Closeddrbrain (Eric Hodel)01/23/2009Actions
Related to Ruby master - Bug #1234: RDoc failure in benchmark/bm_so_meteor_contest.rb at or around line 542 columnCloseddrbrain (Eric Hodel)03/01/2009Actions
Related to Ruby master - Bug #1948: RDoc Fails with Non-ASCII PathnamesCloseddrbrain (Eric Hodel)08/18/2009Actions
Related to Ruby master - Bug #2066: Merge Latest RDoc/RiCloseddrbrain (Eric Hodel)09/09/2009Actions
Related to Ruby master - Feature #5481: Gemifying Ruby standard libraryClosedhsbt (Hiroshi SHIBATA)Actions
Actions #1

Updated by matz (Yukihiro Matsumoto) over 12 years ago

=begin
Hi,

In message "Re: [ruby-core:27722] [Feature #2635] Unbundle rdoc"
on Sat, 23 Jan 2010 23:20:59 +0900, Yui NARUSE writes:

|The rdoc in trunk is outdated and not maintained,
|and latest rdoc is in gen.
|
|I think Ruby 1.9 shouldn't bundle such old rdoc.
|People who needs rdoc should install from gem.

Or bundle newer rdoc?

						matz.

=end

Actions #2

Updated by naruse (Yui NARUSE) over 12 years ago

=begin
Bug #2066 is written by Run Paint Run Run 136 days ago, but it is not yet.

Moreover rdoc has some open bugs for 1 year.
test-all failure and crash bugs need to fixed but not fixed.
I, maintaining Redmine's tickets, hate those unmaintained libraries.
=end

Actions #3

Updated by matz (Yukihiro Matsumoto) over 12 years ago

=begin
Hi,

In message "Re: [ruby-core:27725] [Feature #2635] Unbundle rdoc"
on Sun, 24 Jan 2010 00:15:33 +0900, Yui NARUSE writes:

|Moreover rdoc has some open bugs for 1 year.
|test-all failure and crash bugs need to fixed but not fixed.
|I, maintaining Redmine's tickets, hate those unmaintained libraries.

In that case, should we ask for new volunteer instead of removing it?

						matz.

=end

Actions #4

Updated by luislavena (Luis Lavena) over 12 years ago

=begin
On Sat, Jan 23, 2010 at 12:15 PM, Yui NARUSE wrote:

Moreover rdoc has some open bugs for 1 year.
test-all failure and crash bugs need to fixed but not fixed.
I, maintaining Redmine's tickets, hate those unmaintained libraries.

Is my understanding that rdoc has been updated and maintained by Eric
Hodel, at least eh gem was.

If integration with Ruby is the problem, then removal and optional
installation for the user should be the solution, right?

Luis Lavena
AREA 17

Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupéry

=end

Actions #5

Updated by naruse (Yui NARUSE) over 12 years ago

=begin
(2010/01/24 0:35), Yukihiro Matsumoto wrote:

|Moreover rdoc has some open bugs for 1 year.
|test-all failure and crash bugs need to fixed but not fixed.
|I, maintaining Redmine's tickets, hate those unmaintained libraries.

In that case, should we ask for new volunteer instead of removing it?

If someone maintain rdoc lib in Ruby, it is clear.

--
NARUSE, Yui

=end

Actions #6

Updated by matz (Yukihiro Matsumoto) over 12 years ago

=begin
Hi,

In message "Re: [ruby-core:27729] Re: [Feature #2635] Unbundle rdoc"
on Sun, 24 Jan 2010 00:41:18 +0900, Luis Lavena writes:

|Is my understanding that rdoc has been updated and maintained by Eric
|Hodel, at least eh gem was.
|
|If integration with Ruby is the problem, then removal and optional
|installation for the user should be the solution, right?

That's what I don't understand. Eric has commit privilege. If he
still maintains rdoc gem, I see no reason he doesn't update the
bundled rdoc as well. If he stops maintaining rdoc, we need new
maintainer. If he keeps working on it, I expect him to update bundled
rdoc as well.

						matz.

=end

Actions #7

Updated by naruse (Yui NARUSE) over 12 years ago

=begin
(2010/01/24 0:41), Luis Lavena wrote:

On Sat, Jan 23, 2010 at 12:15 PM, Yui NARUSE wrote:

Moreover rdoc has some open bugs for 1 year.
test-all failure and crash bugs need to fixed but not fixed.
I, maintaining Redmine's tickets, hate those unmaintained libraries.

Is my understanding that rdoc has been updated and maintained by Eric
Hodel, at least eh gem was.

I think so too.

If integration with Ruby is the problem, then removal and optional
installation for the user should be the solution, right?

Yeah, I think so.
rdoc is pure ruby, so it won't be a severe problem,
even if Ruby's installation process needs some changes.

--
NARUSE, Yui

=end

Actions #8

Updated by mame (Yusuke Endoh) over 12 years ago

=begin
Hi,

2010/1/23 Yukihiro Matsumoto :

In message "Re: [ruby-core:27722] [Feature #2635] Unbundle rdoc"
on Sat, 23 Jan 2010 23:20:59 +0900, Yui NARUSE writes:

|The rdoc in trunk is outdated and not maintained,
|and latest rdoc is in gen.
|
|I think Ruby 1.9 shouldn't bundle such old rdoc.
|People who needs rdoc should install from gem.

Or bundle newer rdoc?

I don't know much about the "latest" rdoc, but according to [ruby-core:27667],
I understand that simply updating causes compatibility problem because:

The latest RDoc no longer has the HTML generator at all.

The reporter in [ruby-core:27656] followed proper reporting procedure (i.e.,
tested and patched against 1.9 trunk). Ruby's development process is wrong.
It is too confusing for rdoc to have independent trunk.
In [ruby-core:27667],

I fixed this memory issue by deleting the file.

is equal to "I fixed in my own envirionment!" It does not answer.

I wonder why some standard libraries (RubyGems, Rake, rdoc, etc.) need
to have independent development process and independent release.
I said in [ruby-core:26679], they should be developed and released with
ruby core if they are really parts of ruby core.

--
Yusuke ENDOH

=end

Actions #9

Updated by zenspider (Ryan Davis) over 12 years ago

=begin

On Jan 23, 2010, at 19:03 , Yusuke ENDOH wrote:

The reporter in [ruby-core:27656] followed proper reporting procedure (i.e.,
tested and patched against 1.9 trunk). Ruby's development process is wrong.
It is too confusing for rdoc to have independent trunk.

Then we should eject ALL of standard lib from trunk. Gemify all of them and kick them out the door.

Maybe we should bundle some gems, but they should install as actual gems and be freely upgradable by the user.

Like it or not, rdoc, minitest (and test/unit), rubygems, rexml, and yaml (and others?) are all separate products that are produced independent of trunk. In my opinion, it works BETTER that way, not worse. What doesn't work is having to slow down releases because ruby releases are so few and far between.

=end

Actions #10

Updated by jbarnette (John Barnette) over 12 years ago

=begin
On Sun, Jan 24, 2010 at 10:31 PM, Ryan Davis wrote:

Like it or not, rdoc, minitest (and test/unit), rubygems, rexml, and yaml (and others?) are all separate products that are produced independent of trunk. In my opinion, it works BETTER that way, not worse. What doesn't work is having to slow down releases because ruby releases are so few and far between.

Rake. Rex. Racc.

~ j.

=end

Actions #11

Updated by naruse (Yui NARUSE) over 12 years ago

=begin
On Mon, Jan 25, 2010 at 3:31 PM, Ryan Davis wrote:

On Jan 23, 2010, at 19:03 , Yusuke ENDOH wrote:

The reporter in [ruby-core:27656] followed proper reporting procedure (i.e.,
tested and patched against 1.9 trunk).  Ruby's development process is wrong.
It is too confusing for rdoc to have independent trunk.

Then we should eject ALL of standard lib from trunk. Gemify all of them and kick them out the door.

Maybe we should bundle some gems, but they should install as actual gems and be freely upgradable by the user.

Like it or not, rdoc, minitest (and test/unit), rubygems, rexml, and yaml (and others?) are all separate products that are produced independent of trunk. In my opinion, it works BETTER that way, not worse. What doesn't work is having to slow down releases because ruby releases are so few and far between.

I don't think it is a problem that some libraries are developed out of
Ruby's repos,
until the maintainer fixes bugs created in Ruby's Redmine and update
the lib in trunk.
Current minitest, nkf, JSON, is doing that. (I maintain nkf and JSON)
REXML, YAML, racc are note developed.
rake doesn't but not have reported bugs.

--
NARUSE, Yui

=end

Actions #12

Updated by mame (Yusuke Endoh) over 12 years ago

=begin
Hi,

2010/1/25 Ryan Davis :

On Jan 23, 2010, at 19:03 , Yusuke ENDOH wrote:

The reporter in [ruby-core:27656] followed proper reporting procedure (i.e.,
tested and patched against 1.9 trunk). Ruby's development process is wrong.
It is too confusing for rdoc to have independent trunk.

In my opinion, it works BETTER that way, not worse.

It brings some benefits, but problems actually occur.

  • slow synchronization between the "latest" and ruby trunk
  • empty answer that the issue is fixed in the "latest"
  • neglect of tickets in ruby's redmine
  • incompatible change to the "latest"

These problems do not occur or are detected early if they
are developed in ruby trunk. Nobody would say anything if
such a problem does not occur, I think.

--
Yusuke ENDOH

=end

Actions #13

Updated by naruse (Yui NARUSE) over 12 years ago

  • Status changed from Assigned to Rejected

=begin

=end

Actions #14

Updated by hsbt (Hiroshi SHIBATA) over 5 years ago

  • Related to Feature #5481: Gemifying Ruby standard library added
Actions

Also available in: Atom PDF