Project

General

Profile

Actions

Feature #8539

closed

Unbundle ext/tk

Added by naruse (Yui NARUSE) over 8 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:55530]

Description

How about unbundling ext/tk from Ruby repository?

ext/tk is a bundled extension library for GUI programming with tk.
It is introduced in 1999 and long maintained with CRuby itself.

But nowadays its maintenance is not so active.
Moreover ext/tk is not the de facto standard over Ruby GUI though it is bundled for 14 years.
(maybe because tk is not de facto of GUI toolkit)
GUI libraries for Ruby should compete in the wilds.

So I propose unbundling ext/tk.
It should be another repository for example on github and people should install it as gem.

How do you think?


Related issues

Related to Ruby master - Bug #12681: Gemfied tk issueClosednobu (Nobuyoshi Nakada)Actions
Related to Ruby master - Feature #5481: Gemifying Ruby standard libraryClosedhsbt (Hiroshi SHIBATA)Actions
Is duplicate of Ruby master - Feature #8526: gemify tkClosednaruse (Yui NARUSE)Actions
Actions

Also available in: Atom PDF