Project

General

Profile

Actions

Misc #18122

closed

DevelopersMeeting20210916Japan

Added by mame (Yusuke Endoh) 2 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
-
[ruby-core:105021]

Description

The next dev meeting

Date: 2021/09/16 13:00-17:00
Place/Sign-up/Agenda/Log: https://github.com/ruby/dev-meeting-log/blob/master/DevelopersMeeting20210916Japan.md

  • Dev meeting IS NOT a decision-making place. All decisions should be done at the bug tracker.
  • Dev meeting is a place we can ask Matz, nobu, nurse and other developers directly.
  • Matz is a very busy person. Take this opportunity to ask him. If you can not attend, other attendees can ask instead of you (if attendees can understand your issue).
  • We will write a log about the discussion to a file or to each ticket in English.
  • All activities are best-effort (keep in mind that most of us are volunteer developers).
  • The date, time and place are scheduled according to when/where we can reserve Matz's time.
  • DO NOT discuss then on this ticket, please.

Call for agenda items

If you have a ticket that you want matz and committers to discuss, please post it into this ticket in the following format:

* [Ticket ref] Ticket title (your name)
  * Comment (A summary of the ticket, why you put this ticket here, what point should be discussed, etc.)

Example:

* [Feature #14609] `Kernel#p` without args shows the receiver (ko1)
  * I feel this feature is very useful and some people say :+1: so let discuss this feature.
  • It is recommended to add a comment by 2021/09/13. We hold a preparatory meeting to create an agenda a few days before the dev-meeting.
  • The format is strict. We'll use this script to automatically create an markdown-style agenda. We may ignore a comment that does not follow the format.
  • Your comment is mandatory. We cannot read all discussion of the ticket in a limited time. We appreciate it if you could write a short summary and update from a previous discussion.

Related issues

Related to Ruby master - Misc #14770: [META] DevelopersMeetingOpenActions
Actions #1

Updated by mame (Yusuke Endoh) 2 months ago

  • Related to Misc #14770: [META] DevelopersMeeting added

Updated by zverok (Victor Shepelev) 2 months ago

  • [Feature #18136] take_while_after (or take_upto)
    • I have proposed it once a long time ago, but those examples were convoluted; now I came with clearer ones and explanations of the usefulness.
    • I am ready to work on the PR, if accepted.

Updated by kou (Kouhei Sutou) about 2 months ago

  • [Feature #18143] Add a new method to change GC.stress only in the given block such as GC.with_stress(flag) {...} (kou)
    • This feature is generally useful for debugging GC related problems and writing tests for them.
    • We don't need to implement the same feature multiple times if GC provides the feature by default.

Updated by shyouhei (Shyouhei Urabe) about 2 months ago

Updated by byroot (Jean Boussier) about 2 months ago

  • [Feature #18148] Marshal.load freeze option
    • Useful to deserialize static data that is meant to stay in memory.
    • Useful for in-memory caches.
    • JSON,Psych and MessagePack all added a similar option in the last couple years.
  • [Bug #18141] Marshal load with proc yield strings before they are fully initialized
    • UTF-8 strings are yielded as ASCII-8BIT because their encoding isn't set yet.
    • If the proc freeze the string, Marshal.load raises a FrozenError

Updated by hsbt (Hiroshi SHIBATA) about 2 months ago

  • How about these proposals? Does anyone have an objections for them?
    • [Feature #17297]: Feature: Introduce Pathname.mktmpdir
    • [Feature #17296]: Feature: Pathname#chmod use FileUtils.chmod instead of File
    • [Feature #17294]: Feature: Allow method chaining with Pathname#mkpath Pathname#rmtree
    • [Feature #17295]: Feature: Create a directory and file with Pathname#touch

Updated by hsbt (Hiroshi SHIBATA) about 2 months ago

Updated by duerst (Martin Dürst) about 2 months ago

  • [Feature #18159] Integrate functionality of dead_end gem into Ruby (duerst)
    • It would be very helpful for beginners

Updated by jeremyevans0 (Jeremy Evans) about 1 month ago

  • [Bug #15027] When Struct#each method is overriden Struct#select and Struct#to_a use wrong collections (jeremyevans0)
    • Do we want methods like Struct#select to internally call #each (at least if #each is overridden)? (I'm against making such a change)
  • [Bug #11182] Refinement with alias causes strange behavior (jeremyevans0)
    • I think the current behavior of alias is expected and is not a bug. Can this be closed?
  • [Bug #17568] Thread.handle_interrupt is per-Thread but should probably be per-Fiber (jeremyevans0)
    • Do we want to make Thread.handle_interrupt a per-Fiber setting?
    • Seems confusing to me to do so, considering it's a method defined on Thread.
  • [Bug #17429] Prohibit include/prepend in refinement modules (jeremyevans0)
  • [Bug #17048] Calling initialize_copy on live modules leads to crashes (jeremyevans0)
    • It's still possible to hang the interpreter by calling Module#initialize_copy directly.
    • Do we want to make changes in this area, or is OK to accept the current behavior and close this issue?

Updated by mame (Yusuke Endoh) about 1 month ago

shyouhei (Shyouhei Urabe) hsbt (Hiroshi SHIBATA) please follow the comment format. My dev-meeting setup script ignores your topics.

Updated by shyouhei (Shyouhei Urabe) about 1 month ago

mame (Yusuke Endoh) wrote in #note-10:

shyouhei (Shyouhei Urabe) hsbt (Hiroshi SHIBATA) please follow the comment format. My dev-meeting setup script ignores your topics.

How? Mine is not about a BTS ticket.

Updated by mame (Yusuke Endoh) about 1 month ago

shyouhei (Shyouhei Urabe) wrote in #note-11:

mame (Yusuke Endoh) wrote in #note-10:

shyouhei (Shyouhei Urabe) hsbt (Hiroshi SHIBATA) please follow the comment format. My dev-meeting setup script ignores your topics.

How? Mine is not about a BTS ticket.

Please create a ticket. Alternatively, you can propose another good way to create an agenda markdown automatically.

Actions #13

Updated by mame (Yusuke Endoh) about 1 month ago

  • Description updated (diff)
Actions #14

Updated by mame (Yusuke Endoh) about 1 month ago

  • Status changed from Open to Closed
Actions

Also available in: Atom PDF