Project

General

Profile

Misc #14861

DevelopersMeeting20180718Japan

Added by naruse (Yui NARUSE) 30 days ago. Updated 1 day ago.

Status:
Closed
Priority:
Normal
[ruby-core:87551]

Description

Date: 2018/07/18 (Thu)
Time: 14:00-18:00 (JST)
Place: MoneyForward HQ (beware: new location) (Tokyo, Japan)
Sign-up: https://ruby.connpass.com/event/92314/
log: https://docs.google.com/document/d/1_cKh0LJd18y5CH1MfM6WC1fqh2rpHHZntrBCLTbwRSE/edit
pub: https://docs.google.com/document/d/1_cKh0LJd18y5CH1MfM6WC1fqh2rpHHZntrBCLTbwRSE/pub

Please comment your favorite ticket numbers you want to ask to discuss with your SHORT comment or summary.
(your summary/comment will help us because we don't need to read all of ticket comments)

DO NOT discuss then on this ticket, please.

Past meetings: https://bugs.ruby-lang.org/projects/ruby/wiki#Developer-Meetings

NOTE

Dev meeting IS NOT a decision making place. All decisions should be done at the bug tracker.
Dev meeting is a place we can ask Matz, nobu, nurse and other developers directly.
Matz is a very busy person. Take this opportunity to ask him. If you can not attend, other attendees can ask instead of you (if attendees can understand your issue).
We will write a log about discussion to a file or to each ticket in English.
All activities are best-effort (keep in mind that most of us are volunteer developers).
The date, time and place is scheduled according to when/where we can reserve Matz's time.

Agenda

Next dev-meeting

About 2.6 timeframe

Carry-over from previous meeting(s)

  • [Feature #14784] One-sided Comparable#clamp (with endless/startless ranges) (zverok)
    • more reasonable version of Object#enumerate proposed for the previous meeting.
  • [Feature #14859] Timeout in VM (normalperson)
    • Still needs some work, mainly wondering if the idea of moving this part of stdlib into core VM is acceptable or not. No semantic changes except speed improvement.

From Attendees

(will be edited later)
(if you have a write access permission, please list directly)

  • [Bug #14887] Array#delete_if does not use #delete (shyouhei)
    • Is it by design, or a bug?
  • [Feature #13050] Readline: expose rl_completion_quote_character variable (nobu)
  • [Feature #14850] Add official API for setting timezone on Time (nobu)
  • [Feature #14869] Proposal to add Hash#=== (nobu)
  • [Feature #14877] Calculate age in Date class (nobu)
  • [Feature #14473] Add Range#subrange? (tarui)
  • [Bug #14908] Enumerator::Lazy creates unnecessary Array objects. (nobu)
  • [Feature #14912] Introduce pattern matching syntax (mame)
    • pattern matching
  • opt_to_s (nobu)
    • see below for his patch
  • [Feature #13626] Add String#byteslice! (aycabta)
  • [Feature #14618] Add display width method to String for CLI (aycabta)
  • [Misc #14917] Add RDoc documents to tar ball (aycabta)
  • [Feature #14918] Use Reline for fallback of ext/readline (aycabta)
  • [Feature #14919] Add String#byteinsert (aycabta)
  • [Feature #14916] Proposal to add Array#=== (aycabta)

From non-attendees

(will be edited later)
(if you have a write access, please list directly)

  • [Feature #14111] ArgumentErrorが発生した時メソッドのプロトタイプをメッセージに含む (esjee)
    • Suggestion: include method parameters when generating an ArgumentsError message. Nobu's patch in the issue provides functionality to make writing a ruby gem to provide this functionality possible.
  • [Bug #14878] Add command line argument to deactivate JIT (k0kubun)
    • Please discuss the necessity of the flag and its name in the proposal.
  • [Feature #12306] Implement String #blank? #present? and improve #strip and family to handle unicode (sam.saffron)
  • [Feature #14913] Extend case to match several values at once (zverok)
    • some steps towards better pattern matching
  • [Feature #14914] Add BasicObject#instance_exec_with_block (jeremyevans0)
  • [Feature #14915] Deprecate String#crypt, move implementation to string/crypt (jeremyevans0)

Related issues

Copied from Ruby trunk - Misc #14769: DevelopersMeeting20180621JapanClosed

History

#1 Updated by naruse (Yui NARUSE) 30 days ago

  • Copied from Misc #14769: DevelopersMeeting20180621Japan added

#2 [ruby-core:87636] Updated by esjee (SJ Stoker) 25 days ago

  • [Feature #14111] ArgumentErrorが発生した時メソッドのプロトタイプをメッセージに含む (esjee)
    • Suggestion: include method parameters when generating an ArgumentsError message. Nobu's patch in the issue provides functionality to make writing a ruby gem to provide this functionality possible.

#3 [ruby-core:87736] Updated by shyouhei (Shyouhei Urabe) 19 days ago

  • [Bug #14887] Array#delete_if does not use #delete (shyouhei)
    • Is it by design, or a bug?

#4 Updated by naruse (Yui NARUSE) 18 days ago

  • Description updated (diff)

#5 [ruby-core:87769] Updated by nobu (Nobuyoshi Nakada) 17 days ago

  • [Feature #13050] Readline: expose rl_completion_quote_character variable
  • [Feature #14850] Add official API for setting timezone on Time
  • [Feature #14869] Proposal to add Hash#===
  • [Feature #14877] Calculate age in Date class

#6 Updated by znz (Kazuhiro NISHIYAMA) 15 days ago

  • Description updated (diff)

#7 Updated by k0kubun (Takashi Kokubun) 13 days ago

  • [Bug #14878] Add command line argument to deactivate JIT (k0kubun)
    • Please discuss the necessity of the flag and its name in the proposal.

#8 [ruby-core:87919] Updated by tarui (Masaya Tarui) 8 days ago

[Feature #14473] Add Range#subrange? (tarui)

#9 [ruby-core:87921] Updated by nobu (Nobuyoshi Nakada) 8 days ago

  • [Bug #14908] Enumerator::Lazy creates unnecessary Array objects.

#10 Updated by shyouhei (Shyouhei Urabe) 8 days ago

  • Description updated (diff)

#11 [ruby-core:87937] Updated by sam.saffron (Sam Saffron) 7 days ago

Would it be possible to discuss: https://bugs.ruby-lang.org/issues/12306

"Implement String #blank? #present? and improve #strip and family to handle unicode"

#12 [ruby-core:87946] Updated by mame (Yusuke Endoh) 5 days ago

  • [Feature #14912] Introduce pattern matching syntax
    • pattern matching

#13 [ruby-core:87948] Updated by zverok (Victor Shepelev) 5 days ago

  • [Feature #14913] Extend case to match several values at once
    • some steps towards better pattern matching

#15 [ruby-core:87960] Updated by jeremyevans0 (Jeremy Evans) 4 days ago

  • [Feature #14914] Add BasicObject#instance_exec_with_block
  • [Feature #14915] Deprecate String#crypt, move implementation to string/crypt

#16 Updated by shyouhei (Shyouhei Urabe) 3 days ago

  • Description updated (diff)

#17 [ruby-core:87974] Updated by aycabta (aycabta .) 3 days ago

  • [Feature #13626] Add String#byteslice!
  • [Feature #14618] Add display width method to String for CLI
  • [Misc #14917] Add RDoc documents to tar ball
  • [Feature #14918] Use Reline for fallback of ext/readline
  • [Feature #14919] Add String#byteinsert
  • [Feature #14916] Proposal to add Array#===

#18 Updated by shyouhei (Shyouhei Urabe) 2 days ago

  • Description updated (diff)

#19 Updated by shyouhei (Shyouhei Urabe) 1 day ago

  • Status changed from Open to Closed

Also available in: Atom PDF