Project

General

Profile

Actions

Feature #2348

closed

RBTree Should be Added to the Standard Library

Added by JEG2 (James Gray) almost 12 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Normal
Target version:
[ruby-core:26635]

Description

=begin
The merits of this library have been discussed on Ruby core, with the strengths best summarized by this post:

http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-core/26602

RBTree has now been fixed to run on Ruby 1.9:

http://github.com/skade/rbtree

I think we should now give serious consideration to bringing it into the standard library.
=end


Related issues

Related to Ruby master - Feature #9121: [PATCH] Remove rbtree implementation of SortedSet due to performance regressionClosedknu (Akinori MUSHA)Actions
Actions

Also available in: Atom PDF