Project

General

Profile

Actions

Misc #14921

closed

DevelopersMeeting20180809Japan

Added by shyouhei (Shyouhei Urabe) over 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
[ruby-core:87998]

Description

Please comment your favorite ticket numbers you want to ask to discuss with your SHORT comment or summary.
(your summary/comment will help us because we don't need to read all of ticket comments)

DO NOT discuss then on this ticket, please.


NOTES

  • Dev meeting IS NOT a decision making place. All decisions should be done at the bug tracker.
  • Dev meeting is a place we can ask Matz, nobu, nurse and other developers directly.
  • Matz is a very busy person. Take this opportunity to ask him. If you can not attend, other attendees can ask instead of you (if attendees can understand your issue).
  • We will write a log about discussion to a file or to each ticket in English.
  • All activities are best-effort (keep in mind that most of us are volunteer developers).
  • The date, time and place is scheduled according to when/where we can reserve Matz's time.

Agenda

Next dev-meeting

About 2.6 timeframe

Carry-over from previous meeting(s)

  • [Bug #14887] Array#delete_if does not use #delete (shyouhei)
    • Is it by design, or a bug?
  • [Feature #13050] Readline: expose rl_completion_quote_character variable (nobu)
  • [Feature #14850] Add official API for setting timezone on Time (nobu)
  • [Feature #14869] Proposal to add Hash#=== (nobu)
  • [Feature #14916] Proposal to add Array#=== (aycabta)
  • [Feature #14877] Calculate age in Date class (nobu)
  • [Bug #14908] Enumerator::Lazy creates unnecessary Array objects. (nobu)

From Attendees

(will be edited later)
(if you have a write access permission, please list directly)

  • [Feature #5446] at_fork callback API (eregon) Can we get approval for introducing this? It is solving a real-world issue, in a more reliable way than the various hacks in most Ruby servers.
  • [Feature #11258] add 'x' mode character for O_EXCL (kazu)
  • [Misc #14907] io.c: do not close inherited FDs by default (akr)
  • [Feature #14973] Proposal of percent literal to expand Hash (aycabta)

From non-attendees

  • [Feature #14717] thread: allow disabling preempt (normalperson)
  • [Feature #11076] Enumerable method count_by (baweaver)
    As mentioned in the discussion, Nobu was kind enough to update this to work with current master for Ruby: https://github.com/ruby/ruby/compare/trunk...nobu:feature/11076-Enumerable%23count_by

    As the code is already written I believe it would be an ideal target for 2.6 as a quick win on an often requested feature.

  • [Feature #14954] Add :wait option to RubyVM::MJIT.pause (k0kubun)

    • Since it's not released even in preview2 yet, is it okay to change the behavior?
    • Is there any objection for having the option or the option name?
  • (baweaver)

    • [Feature #14869] Proposal to add Hash#=== (nobu)
    • [Feature #14916] Proposal to add Array#=== (aycabta)
    • [Feature #14912] Introduce pattern matching syntax

    I believe that these three items are related, and personally I could do a lot of very interesting things with Array#=== and Hash#=== that would get us exceptionally close to features discussed in [Feature #14709]

    This to say I would second the inclusion of the first two items as they relate to the third and fourth. It would give Ruby an exceptional amount of power.

  • [Feature #14759] [PATCH] set M_ARENA_MAX for glibc malloc (sam.saffron)
    I would also very much like to see it backported 2.4 and 2.5. It is of enormous value to the ecosystem

  • [Feature #14736] Thread selector for flexible cooperative fiber based concurrency (ioquatix)

  • [Feature #14739] Improve fiber yield/resume performance (ioquatix)

  • [Bug #14968] io.c: make all pipes nonblocking by default (normalperson)

  • [Misc #14937] timer-thread elimination depends on Bug #14968

  • [Feature #14944] Support optional inherit argument for Module#method_defined? (jeremyevans0)

(will be edited later)
(if you have a write access, please list directly)


Related issues

Related to Ruby master - Misc #14770: [META] DevelopersMeetingOpenActions
Actions

Also available in: Atom PDF